Spiky-Haired Dragon, Worthless Knight Forum Index Spiky-Haired Dragon, Worthless Knight
The Comic :: The Forum
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

Couple of Probs.

 
Post new topic   Reply to topic    Spiky-Haired Dragon, Worthless Knight Forum Index -> Trouble?
View previous topic :: View next topic  
Author Message
FlameAlchemist



Joined: 15 Jan 2007
Posts: 19

PostPosted: Tue Jan 16, 2007 2:17 am    Post subject: Couple of Probs. Reply with quote

It will only let me log on if I check the "log me in automatically box."

When I click the "Submit" button, I get an error message saying, "invalid session, please resubmit the form." I get this message about 20 times until it finally posts my message.

I'm normally running Firefox, but I tried Internet Explorer 6 and it did the same thing.
Back to top
View user's profile Send private message
ak-ryuu
Author


Joined: 05 Feb 2006
Posts: 1779
Location: Finland

PostPosted: Tue Jan 16, 2007 2:22 am    Post subject: Re: Couple of Probs. Reply with quote

FlameAlchemist wrote:
When I click the "Submit" button, I get an error message saying, "invalid session, please resubmit the form." I get this message about 20 times until it finally posts my message.


Hmmm.... are you on AOL by any chance? AOL has set up their network in a way that users surf the net via constantly changing proxies, meaning they change their IP address all the time -- so the forum software cannot recognize them. In that case there's really nothing I can do about it I think (I'll have to do some research to see if there is a workaround on the forum end, but I think there really isn't a feasible one).

If you're not on AOL (or having changing IP addresses for other reasons, i.e. surfing via anonymous proxy for example), I can't really think of anything. Are you accepting cookies in your browser? If not, try turning that on and see if it helps (but since "log me in automatically" worked, I guess you are accepting cookies..)

If it is neither of those, I'm clueless at the moment...

Edited to add: I think in the case of AOL, the "log me in automatically" works because then the board can recognize you by the cookie it sets in that case, instead of having to rely on your IP address, so that would be a workaround for your site. I hope this wasn't too technical now :)
_________________
Do you mind? I'm trying to learn about the Okapi.
Back to top
View user's profile Send private message Visit poster's website
FlameAlchemist



Joined: 15 Jan 2007
Posts: 19

PostPosted: Wed Jan 17, 2007 1:12 am    Post subject: Reply with quote

I have AOL on my computer, and have an AOL account, but I have high-speed through a different company and use Firefox.
Back to top
View user's profile Send private message
FlameAlchemist



Joined: 15 Jan 2007
Posts: 19

PostPosted: Wed Jan 17, 2007 1:13 am    Post subject: Reply with quote

I also seem to be logged out every time I make a post.
Back to top
View user's profile Send private message
ak-ryuu
Author


Joined: 05 Feb 2006
Posts: 1779
Location: Finland

PostPosted: Wed Jan 17, 2007 1:20 am    Post subject: Reply with quote

FlameAlchemist wrote:
I also seem to be logged out every time I make a post.


Hmm. Today as well, like in between those last two posts of yours? I checked the IP addresses, and that does not seem to be a problem (you had two completely different ones so far, but I don't think you've been switching between them during one session -- but that is the only reason the forum software should come up with that error message, if it cannot recognize your session for some reason, most commonly because your IP address changed...)

Do you know if you accept cookies from the forum site? If not, can you accept cookies and does the problem go away in that case?

Does anybody else have this problem currently while posting, if so, do you or do you not use cookies?
_________________
Do you mind? I'm trying to learn about the Okapi.
Back to top
View user's profile Send private message Visit poster's website
Kriegel



Joined: 11 Dec 2006
Posts: 336
Location: Elyon's waters

PostPosted: Wed Jan 17, 2007 2:10 am    Post subject: Reply with quote

I just deleted the cookie for this forum to see what happens, so I'm still experimenting. (I'll get it back; it's not hard.)

I use Firefox (the best ever), and I don't know anything about AOH. Sorry.
_________________
When will the angels dance again?
Back to top
View user's profile Send private message Visit poster's website MSN Messenger
ak-ryuu
Author


Joined: 05 Feb 2006
Posts: 1779
Location: Finland

PostPosted: Wed Jan 17, 2007 2:25 am    Post subject: Reply with quote

Kriegel wrote:
I just deleted the cookie for this forum to see what happens, so I'm still experimenting. (I'll get it back; it's not hard.)

I use Firefox (the best ever), and I don't know anything about AOH. Sorry.


Nah, he's not using AOL, so that's not the problem (it is a common AOL symptom due to their "strange" load-balancing, so that was my first guess). I haven't changed or updated the forum software recently, so it cannot be a new bug that I introduced... and I haven't really found any mention of that type of error outside of the "unstable IP addresses" problem anywhere, so I'm a bit clueless at the moment.... both Opera and Firefox work fine for me here, and I haven't heard any error reports from others (yet). But if it's something I can or should fix on my end, of course I want to do that...
_________________
Do you mind? I'm trying to learn about the Okapi.
Back to top
View user's profile Send private message Visit poster's website
Kriegel



Joined: 11 Dec 2006
Posts: 336
Location: Elyon's waters

PostPosted: Wed Jan 17, 2007 3:57 am    Post subject: Reply with quote

FlameAlchemist wrote:
I have AOL on my computer, and have an AOL account, but I have high-speed through a different company and use Firefox.

Oh, wait. Do you have Firefox enabled to accept cookies? Go to Tools>Options>Privacy and cookie options will show up in the middle of the window.
_________________
When will the angels dance again?
Back to top
View user's profile Send private message Visit poster's website MSN Messenger
FlameAlchemist



Joined: 15 Jan 2007
Posts: 19

PostPosted: Thu Jan 18, 2007 1:26 am    Post subject: Reply with quote

my security settings...


Last edited by FlameAlchemist on Thu Jan 18, 2007 1:30 am; edited 1 time in total
Back to top
View user's profile Send private message
FlameAlchemist



Joined: 15 Jan 2007
Posts: 19

PostPosted: Thu Jan 18, 2007 1:30 am    Post subject: Reply with quote

It's working now, I'm not getting that message when I click submit anymore.

My computer is connected to a router through the Ethernet port, and the router is connected to the internet via another cable. I turn the router off every night, and I think my IP changes when it's off.

Edited to add: I'm not getting logged off anymore after I make posts either.
Back to top
View user's profile Send private message
ak-ryuu
Author


Joined: 05 Feb 2006
Posts: 1779
Location: Finland

PostPosted: Thu Jan 18, 2007 1:42 am    Post subject: Reply with quote

FlameAlchemist wrote:
It's working now, I'm not getting that message when I click submit anymore.


Ah, great. Hopefully it was just some one-time freaky occurance then that won't come back :)
_________________
Do you mind? I'm trying to learn about the Okapi.
Back to top
View user's profile Send private message Visit poster's website
Display posts from previous:   
Post new topic   Reply to topic    Spiky-Haired Dragon, Worthless Knight Forum Index -> Trouble? All times are GMT + 2 Hours
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum


Powered by phpBB © 2001, 2005 phpBB Group